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1 Welcome to prepare
All relevant data for a start show file are contained in a drawing, 
whether by yourself or by the technical service provider. So why 
enter everything twice?! 
You can set-up your desk in a couple of minutes to start 
working! 
It's about integrating the coordinates of lamp systems and 
playing timing presets live into the GMA2 console. The ideal 
starting point is a csv File from vwx, Wysiwyg, depence2 or 
capture including all information such as patch, xyz coordinates 
(position & rotation), function and position. But it also works if 
you e.g., only have coordinates. You can also download an 
existing layout from the GMA2 software to build timing presets 
from or Prepare downloads an xml export with all relevant data. 
You can also work in it with just one Excel table. It´s good to 
have this program running at all time during programming, 
cause sometimes you have a new Idea for a delay preset, Effect 
or Gradient preset. But you don´t need this program during your
Show. All Data is in your Desk!
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1 Welcome to prepare
Features of the software:
Patch your desk with one click
Create layouts or load them from GMA2, including all sub-
fixtures / instances
Groups in logical horizontal or vertical order
Gradient (course between two presets)
Timing presets, including all sub-fixtures / instances (in 10 
possibilities per defined center point)
Marcos and Groups create via Excel table
FTP server, for uploading / downloading files (shows, macros, 
profiles, etc.)
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2 Default Settings
Install the prepare App into you application folder

It is best to use the program in the GMA2 network > enter the 
Desk IP in the software (create network environment in advance 
in your system settings)
TelNet must be switched on in the GMA2 to be able to use all 

functions.
No RDM fixture types assigned! > After loading from desk, you 

can swap lamp types with RDM fixtures again.
Setup window (menu window) must be closed during patch 

upload in the GMA2. 
All measurements are in “Meter” / CAD program must be set in 

"Meter” as well.
Syntax to import .xml files into GMA2:
Import "filename“ at (e.g.Group/Image/Preset) Start ID
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3 Supported OS
macOS Catalina
macOS Big Sur
macOS Monterey
Win10
Win11



4 Software Activation

• Enter you´re email and Serial number and you´re ready to        
go.
• Internet connection is required
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5 Import excel table in vwx

• Import our “Excel Export” by right click > import
• All necessary Data fill up automatically.

• Export this table as Format:
CSV Merge (kommagetrennt / comma separated) (*.csv)
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5.1 Export csv from Wysiwyg
• Open a New Wyg File
• Import our Wyg Template
• All necessary Data fill up automatically.
• Start drawing, or Merge you´re already existing Wyg File
• To Export > Click on Data > Columns > prepare > File >    
Export > Save as:

CSV (Comma delimited) (*.csv)
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5.2 Export csv from depence2
• Open your depence2 File
• Import our depence2 Template > Windows > Fixture 
Manager > File > Load Layout
• All necessary Data fill up automatically.
• To Export > Click on File > Export Table > Save as:

Comma separated Values *.csv
Separator   ;
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5.3 Export csv from Capture

• Open your capture File
• To Export > Click on File > Export Fixtures > Save as:

Comma separated CSV File (*csv)
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6 Start Tab

• Choose which Tab you want to enter.
• Deactivate > Deactivate your License on this Computer.
(You need to be online)
• Default Export > Choose USB Export or Network
• Type in Desk User
• Desk IP > Insert exact Desk IP
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7 CAD Tab

7.1 Import Data

• After Import the .csv or a GMA2 Data, you can Match 
Fixtures on 2 different ways (Intern Database / GMA2)
• You can save and load all Data of CAD Tab as a *.ppcad File.
• Prepare saves the last state when closing the application.
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7.1.1 Import from CAD

You can choose you´re csv import File:
• Vectotworks
• Wysiwyg
• Depence2
• Capture
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7.1.2 Import from GMA

• Import from GMA button opens up a PopUp with 3 
different options:
• Load Layout: You can load a Layout from your Layout Pool
• Load XML File: load an XML File from GMA2
• Load Fixture Data: If you are connected with a Desk you can 
load all necessary Data via Network 
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7.2 Show Data and Edit

You can Show your Data and Edit these:
• Mark lines and Edit these directly in prepare App
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7.3 Match Fixture Type

• Match Fixture Database, allows you to match Fixtures 
which already imported in internal Database (some are 
already included by default).
• With Match Fixture GMA you Load Fixtures from GMA. 
These should already be imported in the GMA showfile.
• On both ways is the new Auto Match Function, which 
suggests a choice.
• Orange dot > Auto Match suggestion
• Red dot > Can´t find a Match
• Green dot >  saved
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7.3.1 Edit Sub-Fixtures

• After click on Save you are ready to go back to Main Menu 
by hitting the arrow top left side.
• You can Save Settings as .ppft for later reloading.
• On Button Edit Sub-Fixtures a Pop-up appears. Here you 
can adapt all Sub-Instances from the Fixtures as rotation and 
flipping
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7.4 Groups

• View-Width: Enter your horizontal MA2 Group Window 
width
• Orientation: Horizontal or Vertical
• Sorting: determinate the sorting by Fixture Type or Position
• Click Checkbox for creating Groups of Fixture Types / 
Positions / Functions
• Appearance: Set Appearances Colors sorted by Fixture Type 
and/or Position
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7.4 Groups

• Create XYZ Groups:
Creates 12 groups in all variants of all Fixture Types in all 
axes.
• Top X+ / X- Top Y+ / Y-
• Front X+ / X- Front Y+ / Y-
• Side X+ / X- Side Y+ / Y-
• Create Sub-ID Groups: Building Groups for each Module of 
each Fixture Type and/or Function Groups
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7.5 Layouts

• In this window you can create Layouts  from 3 different angles: Top, 
Side and Front. Just label it, set Rotation if needed, set Orientation and if 
you want disable rotation. In some cases it makes sense to disable the 
orientation, e.g. Subfixtures etc.
• You can set Filters of Fixture Types, Positions or choose a existing Group 
from your Desk.
• On the right side you can put an Image,  under your Layout for a better 
overview. Click List Image to show all Images in your desk or click Upload 
Image to upload an image from computer.
• On bottom left you can set the Fixture to a fixed size.
• Appearance: you can choose Colors for your Layouts such as in Group 
Window.
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7.6 Presets
Choose so many preset forms you want to create.
• Line X> left to right
• Line Y> bottom to top
• Line X<> symmetrical center to sides
• Line Y<> symmetrical center to top & bottom
• Ring from center round outwards
• Clock clockwise open
• Cake<> symmetrical cake open
• Arrow from left to right/ Number defined the angle
• Diamond (square 45°)
• Cross
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7.6 Presets

• Origin:
• Set origin defaults. To create diffrent origins you can adapt 
these parameter, e.g. to create all kinds of presets 5 meters 
to the left just type at x: -5
• For reuse these parameters you can save and load them.
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7.6 Presets
• Options:
• On right side you can choose which angle you need, disable 
rotation and Add SubIDs. With click on the checkmark the 
software calculate also all Sub Fixtures in each Fixture.
• Min/Max Value is for timing (in seconds), you can also 
change this easily later in the desk.
• If you create Values, it stands for 0-100% and at FX Phase 
from 0-xxx°. Grouping regards grouping for the presets. At 
Path you can choose a Ramp low/normal/high.
• Mirror even stands for mirroring in combination with
groups
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7.6 Presets

• At Filters you can choose in these Tap also an Attribute. If you need 
delay Presets, it´s better if you take all (don´t set any Filter), if you want to 
have FX´s it´s necessary that you set Filters.
• Like before you can also take a group of Fixtures which you created in 
your showfile.
• Create FX Groups creates Groups instead of presets.
• At Gradient Presets you can select from 2 presets from your desk and 
create a new Gradient one. The Gradient remember the last choice.
• E.g. red to white in Line X > is on left side red and will go to white on 
right side.
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8 Excel Tab

8.1 Macros

• With our supplied Excel Sheet you can write down Macros. 
Just mark and copy one and press Create Macro in prepare, 
then enter a pool number and you got this Macro on 
demand.
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8.2 Groups, Layouts and Presets

• With our supplied Excel Sheet you can copy (e.g. Groups) 
and press Match Fixture Types. 
• Thereafter you can create Groups, Layouts and Presets 
from Excel Table by copying one of these into your clipboard 
and press create (Group/Layout/Presets)
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9 Fixture Types

• In this pool you can upload your personal Fixture Types. A 
little stock of common Fixtures are in by default. These is the 
pool if you do Match Fixture Types Database.
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10 FTP

• It´s a FTP Server as you know it. Loading files e.g. Showfiles, 
Images, Profiles etc. up and down.
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8

11 Credits / License

Pysftp is under BSD License
Copyright © 2014, Dundee Media & Technology, Inc
All rights reserved.

PyInstaller is under GNU License
Copyright © 2010-2021, PyInstaller Development Team Copyright (c) 2005-2009, Giovanni Bajo
Based on previous work under copyright (c) 2002 McMillan Enterprises, Inc.

SciPy license is under BSD License
Copyright © 2001, 2002 Enthought, Inc.
All rights reserved.
Copyright © 2003-2019 SciPy Developers.
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are 
met:
Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the 
documentation and/or other materials provided with the distribution.
Neither the name of the organization nor the names of its contributors may be used to endorse or promote products derived from this 
software without specific prior written permission.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the 
"Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, 
distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the 
following conditions:
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE 
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS 
OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR 
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
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